Blanked my EGR valve and WOW! | Vel Satis Knowledgebase | Vel Satis Forum

 
You must be logged in to post Login Register


Register? | Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

Blanked my EGR valve and WOW!

UserPost

20:34
May 2, 2014


lexi

Guest

11
0

  I am not familiar with the engine but you could try cleaning EGR valve and refitting all.

     I think that other things like injectors can be damaged when limp mode happens and egr is not working properly.

12:55
May 4, 2014


800dr

Guest

12
0

Post edited 12:57 – May 4, 2014 by 800dr


Hi Luke,

I think that EGR must be pluged at the ECU even you blanked it: unplug the EGR display injection fault.

08:18
May 6, 2014


LukeLeeson

Guest

13
0

Hi All, The fault light went out the next morning and hasn't come on since, I had just changed the auto box oil and engine oil/filter so god knows wat set it off but iv tried to get it back on by thrashing it n it seems fine. Have to wait and see.

08:36
May 6, 2014


Battlecat

Guest

14
0

That's good news Luke. Keep us upto date with your mod.
Did you have much trouble changing your ATF fluid? I had mine partially changed at a garage but that costs a bit. I have about 7 litres of Millers in my shed.

15:09
May 7, 2014


LukeLeeson

Guest

15
0

Still hasn't come back on Smile and The ATF was a bit of a bastard as its really tight and there's a mini dip stick held in with a clip and once i got that off i had to get a long piece of pipe and feed it through gaps of the engine bay into the filler hole then connect a big oil syringe to squeeze it in lol Just slightly annoying and time consuming.

21:49
May 7, 2014


lexi

Guest

16
0

   Take a plastic filler and put the spigot into long hose that you have fed down into filler hole.

         This will let you pour from bottle or can. The filler will be sitting up at rocker cover height.

07:28
May 9, 2014


LukeLeeson

Guest

17
0

How much did yours hold lexi? or does anyone else know? i went on the dip stick as i can find out what its meant to take

20:53
May 9, 2014


lexi

Guest

18
0

  If you get the transmission hot and it is up to the proper level, I think

  you will drop around 4 litres.  It can vary with levels and temperatures.

       I would always check on dipstick anyway. Not too much or too little.

17:44
May 12, 2014


800dr

Guest

19
0

Normally, you must drop exactly 3.3 liters (if start level was good)

21:14
May 12, 2014


lexi

Guest

20
0

    You are probably right Arn.  I am thinking Xantia with ZF box is a bit more.

         I usually put 3 litres in and then a little at a time till dipstick is good.  Check again after a long run.

No Tags

 

Comments are closed.