Blanked my EGR valve and WOW! | Vel Satis Knowledgebase | Vel Satis Forum

 
You must be logged in to post Login Register


Register? | Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

Blanked my EGR valve and WOW!

UserPost

20:47
April 24, 2014


LukeLeeson

Guest

1
0

Hi all, Just made some blanks and blanked my EGR valve off….. its made it a new car! Its faster, pulls off better and smother and is also doin 34.4mgp and thats not driving economically either. The only down side i can see atm is the emissions may be a little higher but i no a man for the MOT's ;) Ive covered 100 miles so far and all is well but ill keep you posted.

 

just if anyone wants to know i made the blanks out of some spare tin i had, just used the ends of the original pipe from the turbo to the EGR as a template and cut it out n bolted them back on.

07:03
April 26, 2014


Battlecat

Guest

2
0

Good on you Luke. That's a job I was thinking of doing but with other things going wrong with my 3.0 dci have put it off. Thought it might be a cure to stop the cloud of smoke that appears when accelerating hard. It worked on my old rover 75.
What model is your V S and did you have any problems with warning lights etc?
Keep us updated on the cars performance.

07:18
April 28, 2014


LukeLeeson

Guest

3
0

Mine is a V S 3.0 dci privilege and ye it did stop the smoke. Iv done 288 miles now and had no problems or warning lights plus its still doing better on fuel, I haven't been going steady at all and its at 31 mpg. I highly recommend it as an upgrade! really easy to do as well (with the exception of undoing the bolts with very little room). 

16:59
April 28, 2014


800dr

Guest

4
0

Warning light issue: the button is known for its weakness

17:08
April 28, 2014


Battlecat

Guest

5
0

LukeLeeson said:

Mine is a V S 3.0 dci privilege and ye it did stop the smoke. Iv done 288 miles now and had no problems or warning lights plus its still doing better on fuel, I haven't been going steady at all and its at 31 mpg. I highly recommend it as an upgrade! really easy to do as well (with the exception of undoing the bolts with very little room). 

Re the EGR blanking plate, Might try it sometime. With regard to you getting 31mpg, that seems very low for a 3.0 If mine goes below 40mpg I think somethings wrong. Mind you I don't tend to thrash it, these days I tend to keep below 70mph, but then I am turning into my dad!!!Smile

20:12
April 28, 2014


lexi

Guest

6
0

 What do you get if you are trying for MPG on decent long journeys with 3.00 dv6?

21:35
April 28, 2014


Battlecat

Guest

7
0

 What do you get if you are trying for MPG on decent long journeys with 3.00 dv6?

On motorway runs at a steady 70mph using the cruise control I have achieved 45 mpg. I once followed a coach on the M11 and got 47. I always make sure the tire pressures are correct to save drag. Blimey I even sound like my dad now!!

19:19
April 29, 2014


LukeLeeson

Guest

8
0

I've got to admit i haven't ever tried for the MPG Confused Iv moved on from a Focus ST and an Astra VXR so im enjoying being able to thrash it everywhere and still get above 21 MPG lol I did think about getting it mapped but i think i may be pushing it then Laugh Just out of interest what age are my fellow Vel Satis owners as im only 24 and people look at me strange when i get out of mine lol

16:46
April 30, 2014


lexi

Guest

9
0

   Luke:  I can see you ending up with a 3.5.  

 

     im only 24 and people look at me strange when i get out of mine lol

 

    They are probably looking at car and wondering what it is?

       I am that old I have stopped buying green bananas!!

20:01
May 2, 2014


LukeLeeson

Guest

10
0

Hi All me again, Got bad news…. The mighty Vel Saits is telling me there is a fuel injection fault and has gone into slow mode Confused I know this is a common problem with these but iv yet to find a definitive answer as to what causes it….. I may try having the EGR valve deleted via the ECU as i blanked it but the ECU still thinks its there and thats the only thing i can think of tht may have set it off… even tho its been a week and 300 miles since i blanked it. Any ideas? Cheers.

No Tags

 

Comments are closed.